How to run an API which requires configuring and tunneling ports over SSH

feature_request

#1

I was trying to create a convbot for running my APIs, but I was getting the following error when I ran the API in the gambit -
Not found because of proxy error: Error: getaddrinfo ENOTFOUND xyz.com xyz.com:443
(changed the actual address to xyz).
When I ran this API in Postman, I got a success response, but it isn’t working in the gambit.
Usually, I require to tunnel to some servers/ports through Putty to run my APIs, which may be why tarsbot is unable to use the same settings.
How do I handle such scenarios? Please help.


#2

@gsnap6

This looks like a config issue, please ping me on the live chat from the TARS Dasboard and I will be able to help you better.


#3

Hey @gsnap6,

Check this answer for a a similar question. See if it works: